Step-by-Step
Creating a Web Animation
With Director

In this Step-by-Step Card, you will use basic Director commands to create a Web banner animation.
To do this, you will use graphics that come with the Director Academic software.

Note: It'sagood idea to complete Lesson 1: Introducing Director 7 included on the Director
Academic CD before you perform these steps.

Setting up a movie

Open the Director Academic application. A number of windows are displayed.

Tip: If your monitor allows it, you may want to set it to a high resolution to make room for the
many windows.

The Stage window is the first window that you need to be visible. First, you'll check the settings for
the size of the Stage.

Choose Movie from the Modify menu; then choose Properties from the submenu. Make sure that
Custom is chosen for the Stage size, with a window size of 464 by 60. The Default Palette size
should be Web 216 so that Director knows to use a Web-safe color palette for this animation. Click
OK when you're done.

Your Stage should look like this:
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Next you'll tell the movie that you do not want it to loop.

Choose Control Panel from the Window menu. The button in the upper-right corner of the control
panel shows either a looping arrow, which indicates that the movie will loop, or an arrow pointing to a
vertical line, which indicates that the movie will not loop. Select the non-looping option. Leave the
control panel open.

Control Panel
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Creating media
In these steps, you'll create a vector graphic.

1 Choose Vector Shape from the Window menu. A Vector Shape window appears. Click the filled
rectangle button (the rectangle filled with gray) and create a rectangle in the work area
approximately the size and shape of the Stage.

el KW
]

[ I

2  (Click the gradient fill button (located in the Vector Shape window below the Closed box). The
rectangle is filled with a gradient fill. The two colors on the left and right side in the bottom row
dictate what two colors are used for the fill.

Now make the rectangle appear to be a sunrise.

8 Click the left gradient color button and select a light pink color. Click the right gradient fill button
and select a dark blue.
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4  In the Vector Shape window, choose Radial from the pop-up menu where Linear is displayed.

5 Enteravalue of 30 in the Y Offset text box, which is located at the upper-right of the Vector Shape
window. You may have to expand your window to see it.

Tip: When entering numbers in these boxes, use the number keys at the top of the keyboard, not
the number key pad on the right of the keyboard.

6 Type “Sky” for the title of this cast member; then close the Vector Shape window.
Next, you'll add some text.

7 Choose Text from the Window menu. Create some text that includes the words “The Bean
Factory.” Use 24 point Helvetica bold for the font, size, and style.
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Name this cast member “Title.”
Next, you'll create another text cast member.

This time instead of closing the text window, click the plus sign in the upper-left of the Text
window. Type “To order” and change the size to 12 points.

Name this cast member “Order.” Close the Text window.

If the Cast window is not displayed, choose Cast from the Window menu. In the Cast window, you
can see the three cast members that you have created.
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Now you will work with sprites. Sprites control the location, appearance, and other features of cast
members while they’re on stage. Sprites can be easily confused with cast members. If you created
ared circle in the Vector Shape window, that circle would become a cast member and appear in the
Cast window.

If you place two of those circles on the Stage, each of them becomes a sprite. You can have one of
the circles zoom to 400% and then fade out while the other circle bounces up and down on the
Stage as it turns blue. In this instance, the same cast member is being called on to be on the Stage
twice at the same time. There is one cast member, but two sprites. Regardless of what you do to
modify the sprite in the form of stretching, fading, and so on, you are not changing the cast
member itself.

Creating sprites

Drag the Sky cast member from the Cast window to the Stage. A sprite overlay window is displayed.

B

Choose Sprite Overlay from the View menu; then choose Show Info from the submenu. Choose
Sprite Overlay from the View menu; then choose Show Paths from the submenu.

Move and resize the sprite using the corner handles so it fills the entire Stage.
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4 Drag the Title cast member from the Cast window to the Stage. Place the sprite in the lower part of
the Stage.

5  With the Title sprite selected from the Stage window, go the Score window and choose

Background Transparent from the Ink pop-up menu. This removes all of the white space around an
image or text.

6 Place the Order cast member on the Stage as shown. With the Order sprite selected, choose
Background Transparent from the Ink pop-up menu.

Your windows should look similar to this illustration:
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7  Choose Save from the File menu. Type a name for this movie; then click Save.

4 Creating a Web Animation With Director m Step-by-Step Card



Animating sprites

Next you'll make the Title sprite move from the bottom of the Stage to the top with a technique
called fweening. When you define the beginning and end points of an animation, Director is able
to create all of the frames in between.

In the Score window, click the Title sprite. A circle appears in the upper-left corner of the sprite.
This handle allows you to tween the sprite. Holding down the Shift key, drag the circle up until it is
just short of the top of the Stage. (Holding down the Shift key limits the motion when you drag to
90 degree angles.) When you are finished, two circles appear, a green one to show where the
animation starts and a red one indicating where it ends.
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Preview the animation by clicking the rewind button (the button on the left) and then the play
button (the button on the right) on the control panel.
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Now take a look at the Score. Dots called keyframes are displayed in the first and last frames of the
Title sprite. Keyframes are points in a sprite’s time on stage that are important. In this case, they are
the beginning and end points of its tweening.

You can add more properties to a keyframe by using the keyframe options in the Score window.

Select the keyframe in frame 1 of the Title sprite. Set the blend value near the top of the Score
window to 0. You will need to type a 0 in the box as there is not a 0 option in the pop-up menu.
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The Title sprite is no longer visible on the Stage.
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4  (lick the rewind button and then the play button on the control panel. You have made your first
animation.

5 Choose Save from the File menu to save your animation.

Importing files

Director allows the importing of many different file types. In these steps, you will import a number
of files and add them to the animation banner.

1 Choose Import from the File menu.

2 Inthe dialog box that appears, navigate to the Learning folder inside the Director 7 Academic
folder. Open the Tutorial Media folder. Three files should be in this folder: Coffeeman.swf,
Cup.bmp, and Horizon.bmp. Select one of these file names; then click Add All. The files are all
added to the list at the bottom of the dialog box. Click Import.

8 IfanImage Options dialog box appears, select Stage for the Color Depth and select “Same
Settings for Remaining Images.” This makes the imported files adhere to a Web-safe color palette
like you set in the movie preferences at the beginning of this activity. Click OK.

Take a look at the Cast window. It contains the three cast members that you created plus the three
new members that you just imported.
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Creating additional sprites

1 Select frame 1 of channel 4 in the Score. It's a good idea to always select the frame in which you
want the new sprite to appear before you drag the cast member to the Stage. If you don’t select a
frame first, Director creates the sprite in the frame that you are currently in. That may or may not be
what you want.
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Drag the cast member Coffeeman.swf (a Flash movie) to the left side of the Stage.

Stage

Add the Horizon cast member to the bottom of the Stage.

If the Horizon sprite isn’t selected, select it. In the Score window, choose Background
Transparent from the Ink pop-up menu. Note that the white background is no longer displayed, but
there is a white border around the edge of the horizon. This is because the horizon is anti-aliased,
which is a method of smoothing edges by blending them with nearby colors. You can remedy this
by choosing Darkest from the Ink pop-up menu.

Performing additional tweening

In the Score window, select frame 1 in sprite channel 6. Drag the Cup cast member to the Stage
and place it on top of the Coffeeman sprite. Choose Background Transparent from the Ink pop-up
menu. While holding down the Shift key, drag the Cup’s tweening handle to the right side of the
Stage.
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In the last frame of this animation, the Cup should appear on the right side of the screen.

Select the last frame of the animation in the Score window and see that the Cup appears in the right
place. If it is not placed correctly, adjust the tweening handles.

Stage

While the last frame of the cup sprite is selected, you will add some rotation.
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8 Inthe Score window, enter 720 for the Rotation. Director will tween between the rotation settings
of the first keyframe (0 degrees) and the rotation settings of the second keyframe (720 degrees).
That's two full spins.
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4 Rewind the movie and check it out.

5  Save the movie.

Using behaviors

Behaviors are frequently-used Lingo scripts that Director provides so that you can add interactivity
to your movie without knowing scripting commands.

1 Toaccess the available behaviors, choose Library Palette from the Window menu.

Behaviors are applied to sprites by dragging the behavior’s icon to the sprite on either the Stage or
the Score. Next you'll create a link to a URL by dragging the URL behavior to the Cup sprite on the
Score.

2 In the Library palette, choose Navigation from the pop-up menu. In the dialog box that appears,
enter a URL for this link to go. Click OK.
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8 Drag the “Hold on Current Frame” behavior in the Library palette to the last frame of the behaviors
channel in the Score.
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4 Rewind the movie and play it. When the end of the movie is reached, the Flash movie
(coffeeman.swf) continues to play. This is the animation on the left side of the banner. Try clicking
the cup (right side of the banner). If you have an Internet connection available, this should open
your browser software and take you to the URL that you specified earlier.

5 Save your movie.

Exporting your file as a Shockwave movie

1 Choose Save As Shockwave Movie from the File menu.

2 Name your movie. Shockwave movies need to have a .dcr suffix added to them to be served
properly from Web servers. If you don’t add .dcr to the name of the file, Director adds one for you.
Select “Generate HTML” and “Preview in Browser.” Click Save.

Your browser opens and your movie is shown.
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Note: You need to have the Shockwave plug-in installed in your browser to properly view the
movie. If you do not have the latest plug-in installed, go to http://www.macromedia.com to
download it.

8 Choose Quit from the File menu.
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